找到結果: 258
作者: Zoella, 13.03.2022 at 07:41

To the meta team: Dave will personally fire you and scrap your bread rations for this month if u don't finish the map.


At the moment, the meta team is waiting on me to fix some more bugs with the map editor, so don't be too harsh on them. There's not much more they can do until then.

I did go ahead and cut their bread rations though, because why not.
載入中...
載入中...
作者: Zoella, 12.03.2022 at 10:25

Ukraine must be freed from its current oppressive government. Anything that comes out of Ukraine is debunked within 48 hours. Oh also, I wonder why Zelensky was in the pandora papers. Any ideas?


One of my former employees was Ukrainian, living in Kiev. I remember him telling me, 2-3 years ago, how all they (the Ukrainian people) wanted was for Russia to leave them alone and stop meddling in their country. I believe him.

Say what you want about the Ukrainian government (no government is perfect), but I still don't think they deserved to be invaded.
載入中...
載入中...
作者: SpicerIQ, 09.03.2022 at 06:47

My scenario is great. But these low ranks don't know how to host scenarios. They just host maps because they don't know what a scenario is or where they are found. This is understandable since most noobs just click on "New Game" then play whatever they see--which in this case is my map because I decided to promote both my map & scenario.


I've updated it so Promo'd scenarios will show up in the New Game menu too.
載入中...
載入中...
I am doing the best I can with the latest spike, as I did with the previous ones. I never let an opportunity pass by without trying.

All new accounts still get 7-days of free premium, so yes new players have access to all maps for free, at least for the first week. We implemented this during the first Coronavirus spike, and it's still in effect now.

We are continuing to advertise at the same level as we have for the last 6 months or so. I'm looking into starting up Bing ads again too.

Sean Spicer has made a pretty good Ukraine vs Russia scenario, check it out if you haven't already.

Hopefully we can release World Map 2.0 by next week... it's very close to being done, just working out a few bugs. I've been working heavily on it these last 2 weeks. It may help keep some activity going for a longer term this time. (at least I hope so...)
載入中...
載入中...
Okay I was able to reproduce this, thanks. Added to the list

Notes to self:
To reproduce --
1) setup a game with 2 players on opposing sides
2) for player 1, pick a city and make sure there are stealth units in it
3) for player 2, move a stack within stealth detection range of player 1's city
4) from player 2's screen, player 1's stealth units will appear in the unit hover menu, but not in the city menu
載入中...
載入中...
作者: s_12fd93ef642bc54826, 04.03.2022 at 12:01

I tried to conquer some states, but although I win it doesn't mark it as mine.


It sounds like this is not really a bug... see @Seanathan Spicer's answer.

However if you think it is still a bug, please open a new bug report using the correct format. See here: HOW TO REPORT BUGS (read this first). Thanks!
載入中...
載入中...
作者: clovis1122, 08.03.2022 at 10:27

If I hover over the city I can see the stealth units, but I cannot see them in the city. Seeing them in the city is useful as it shows the unit stats and description.




Thanks Clovis for following our bug report template.

Anyway what map is this happening on, so I can test?
載入中...
載入中...
作者: Zoella, 07.03.2022 at 17:23

Atwar players suggesting ideas on forums



It's true.

You might be surprised to learn though that I do read every idea that's suggested. I just don't comment on them.

There have been some really good suggestions at times; there have also been really stupid ones; and then there are some things I was already planning to do anyway. You'll never know which is which, unless/until you see the updates come out. (And for that you have to be patient... I've already got enough on my to-do list to take us through the next 3 years...)
載入中...
載入中...
I've just completed a big update to the map editor which I want to tell you a little bit about. In short:

- I've re-written a big portion of the code relating to how maps are saved.
- Solved a huge security vulnerability which I discovered related to map saving.
- There is now a significantly faster map saving process.
- Maximum file size for the map background has been increased from 20 to 32MB.
- Maximum file size for city/country/unit images has been increased from 1 to 10MB.
- Fixed a bunch of bugs throughout the Map & Scenario editors.




The full story, if you want to know:

About one week ago I was passing the weekend working on atWar (because, apparently, that's what I do for "fun" on the weekends). I was digging into the Map Editor code to fix a couple things the Meta Team needed related to our forthcoming World Map 2.0. While doing that I happened to discover a horrible security vulnerability which I had never noticed before. It was so bad that I immediately took down the entire Map Editor to prevent anyone from exploiting it.

Even though the vulnerability had been there for years -- definitely from before I was around -- I just couldn't conscience leaving it up after I discovered it. It's one thing when you don't know it exists, but to knowingly leave something that bad there would have been unpardonable.

The problem was part of the code that handles the saving of maps. I had been wanting to replace the map saving code for a long time anyway, for other reasons -- mostly because it was so terribly slow and inefficient. So I set out to re-write the entire map-saving functionality.

At first I thought I could do it over the weekend, but that quickly proved too optimistic as one day turned into another. I ended up working on it non-stop (except for sleep breaks) for 6 days. I literally put every other thing I had to do on hold and worked on this exclusively. I also had to cut back my goal of replacing ALL the map saving code and settle for just the most important parts of it, or else it would have taken a month and I couldn't afford to neglect my other tasks that long.

In the end though, I did replace significant portions of the map-saving code, and I'm happy to say the end result is definitely faster and more efficient. According to Mobster, a big map that used to take him 10 minutes to save, now takes only 3 minutes. For me, cloning the World Map and then saving it used to take about 2 minutes -- now about 30 seconds.

While I also fixed several bugs along the way, please note, I have NOT fixed everything. Not by a long shot. There are still plenty of other bugs floating around in the map editor, and I will keep chipping away at them as time goes by. If you happen to find one, please let me know by opening a bug report here: https://atwar-game.com/forum/topic.php?topic_id=39713. (I'm saying this now because I know there will be people who come along later and say "Dave, you said you fixed the map editor, so why am I still getting (insert bug here)??" -- I haven't "fixed the map editor", I only fixed a small part of it!)

I've also made progress on another project which I call the "Map Unbugging Project" (or the "Map Un-fucking Project", if you prefer)... I'll post separately about that soon, but suffice to say I've been going through and fixing a lot of broken maps that have been sitting around collecting dust. Keep an eye on the Map Unbugging Log for updates.
載入中...
載入中...
Wow, that's crazy.

Thank you WD for the screenshots. That makes it very clear.

Maybe what I need to do is add a conditional to whatever code watches the hitbox... to check if the city is a port or not, before deciding to allow a sea-based stack in. If I can find wherever that is....
載入中...
載入中...
27.02.2022 在 [CLOSED] Bug Report
Closing this since I can't reproduce it, and the report is so old now that probably whatever it was has been fixed long ago. If not though, if you still have any problems please let me know by opening a new bug report.
載入中...
載入中...
Closing this since I can't reproduce the issue and the OP did not reply with any further info.
載入中...
載入中...
I know you already know this @Mobster but this issue is fixed as of the last map editor update.

By the way I did also increase the max background size to 32MB. I did several tests with a 28MB JPG image and it was working fine, so the file's size does not seem to be an issue anymore.

However, there IS still a problem with larger dimensions images. I wanted to increase it but when I tried it started fucking up in strange ways, and I haven't been able to figure that part out yet. The largest safe dimensions seem to be 9999x9999. Someday I'll figure out how to solve that part of it, but that's a different issue.
載入中...
載入中...
This is fixed as of the most recent map editor update. I've (almost) completely replaced the map saving system, so errors like this don't happen anymore.

I also fixed ALL the existing maps with DB/Filesystem version mismatch errors (like I mentioned before... the most common cause of "error loading paths" messages.) Unfortunately your testasdasdsa map is not one of these... it has no paths at all. When you last saved it it must have failed and never uploaded the borders, so I can't fix that. At least it was not an important map tho
載入中...
載入中...
Update: with the most recent map editor update I've switched the default to use the raw .xaml files and NOT the .zip files. Zips are still there, but only used as a fallback if the xamls can't be found. This has speeded things up a bit. Next step is still the same as I talked about earlier... I need to unzip all from the existing 18K+ maps on the server and then we can get rid of zip.js completely.

From your perspective nothing should have changed, except for maps loading faster now.
載入中...
載入中...
Probably some weird merging of battles that dragged your ship somewhere it shouldn't go. Will be hard to reproduce though. I'll leave this open...
載入中...
載入中...
I don't appreciate your attitude. Not just this bug report, I mean other times in the past where I've tried to help you with map issues and you've absolutely bitten my head off for no reason. And, lets not forget how you defaced this map with messages about me during the "November riot". So just so we're clear, I have zero interest in helping you personally, and I could really care less whether your map is broken or not.

Now that we're clear... since I genuinely do want to fix the bugs around here, and I've been putting a lot of effort into fixing the map editor specifically, I will use the information from this bug report and try to find a fix. I do this for the benefit of other map makers who might encounter the same problem -- not for you.




Notes to self:

- scenario ID 15572
- map ID 8457
- reproduceable. full error message:
|SYSTEM - Error: Uncaught TypeError: Cannot read properties of undefined (reading '0'), Script: https://atwar-game.com/java/game/atwar.game.min.js?v=202202250831, Line: 1, Column: 650618, Stack Trace: TypeError: Cannot read properties of undefined (reading '0')
at CreateVisual (https://atwar-game.com/java/game/atwar.game.min.js?v=202202250831:1:650618)
at li.$GenerateImage (https://atwar-game.com/java/game/atwar.mapengine.min.js?v=202202250831:1:25363)
at li.GetImage (https://atwar-game.com/java/game/atwar.mapengine.min.js?v=202202250831:1:25279)
at hi.$UpdateIconImageInternal (https://atwar-game.com/java/game/atwar.game.min.js?v=202202250831:1:654228)
at hi.UpdateIconImage (https://atwar-game.com/java/game/atwar.game.min.js?v=202202250831:1:654037)
at he.ChangeCountryOwner (https://atwar-game.com/java/game/atwar.game.min.js?v=202202250831:1:327045)
at he.PlaceScenarioData (https://atwar-game.com/java/game/atwar.game.min.js?v=202202250831:1:315656)
at he.Load$1 (https://atwar-game.com/java/game/atwar.game.min.js?v=202202250831:1:311525)
at G.ChangeState$1 (https://atwar-game.com/java/game/atwar.game.min.js?v=202202250831:1:174643)
at G.$OnGameStateChanged (https://atwar-game.com/java/game/atwar.game.min.js?v=202202250831:1:170911)|

- need to copy both map and scenario to test server for debugging (see TaskBoard: "World Map 2.0 / write script to copy maps from test to live")
載入中...
載入中...
27.02.2022 在 [OPEN] @Dave, Reminder
作者: DeepFriedUnicorn, 12.10.2021 at 15:59

Cool man, much appreciated.
However, I've done this before and was doing a few times recently. Bugs still tend to be there. Like, Missing borders and sometimes Cities. I come back 2 or 3 weeks later,(and/or Year's) re-uploading the image in-between. I use to ask Admins to manually reset Map maker server thingy often too. But still the same bugs or stranger pop up.

Any advice at all?

The only reasons I think it's on my end is because I tried on 3 PCs, a phone and my account actually got banned before and I believe I got demoted a level before. I think. Something to do with my account. Somehow...? Maybe reset it. Delete then make a new account?
maybe somehow had to with Caches on each individual players map count?


So... I just completed a pretty significant update to the map editor... would you mind trying it again and let me know if you still have any problems with it now?

There are still bugs in the map editor I'm sure, but I just fixed a bunch of things including the ghost borders issue, so hopefully you'll have better luck with it this time...
載入中...
載入中...
Note to self, see maps: 13151,13284,14663,15165,25583,28424
Cloned 'GGG Part 4: Alternate 7 Years War' (13284) into '2022-02-27 test2'
載入中...
載入中...
作者: Mobster, 27.02.2022 at 03:14

I can't make a topic in the Turkish forums right now, does it have something to do with this?

(This happens when I try to post a new topic:)



Yes, my fault. Sorry. I knew that was too easy a fix

Try it now, should be okay...
載入中...
載入中...
Did some digging in the logs, and unfortunately this seems to be a not-infrequent error. I'm not sure yet how to reproduce it, but will keep this open until I do.

Note to self -- full error message as logged:

|SYSTEM - Error: Uncaught TypeError: Cannot read properties of null (reading 'get_Map'), Script: https://atwar-game.com/java/game/atwar.game.min.js?v=202112171947, Line: 1, Column: 598530, Stack Trace: TypeError: Cannot read properties of null (reading 'get_Map')
at Xt.RecalculateLayerObjectBounds (https://atwar-game.com/java/game/atwar.game.min.js?v=202112171947:1:598530)
at Xt.Clear (https://atwar-game.com/java/game/atwar.game.min.js?v=202112171947:1:598062)
at me.Clear (https://atwar-game.com/java/game/atwar.game.min.js?v=202112171947:1:313900)
at _e.CleanPreviousTurnData (https://atwar-game.com/java/game/atwar.game.min.js?v=202112171947:1:404001)
at z.ChangeState$1 (https://atwar-game.com/java/game/atwar.game.min.js?v=202112171947:1:180834)
at z.$OnGameStateChanged (https://atwar-game.com/java/game/atwar.game.min.js?v=202112171947:1:177654)
at t.c [as $handlerDelegate] (https://atwar-game.com/java/mscorlib.min.js:65:225)
at t.ProcessMessage (https://atwar-game.com/java/atwar.core.min.js?v=202012080610:1:49045)
at xn.$OnMessageReceived (https://atwar-game.com/java/atwar.core.min.js?v=202012080610:1:86709)
at xn.OnDataReceived (https://atwar-game.com/java/atwar.core.min.js?v=202012080610:1:85827)|
載入中...
載入中...
I have no idea what you're trying to tell me, sorry... Can you be more specific? See https://atwar-game.com/forum/topic.php?topic_id=39713
載入中...
載入中...
Yeah the finances tab is always wrong, has been for a long time

I'll leave this open but it will probably be a while before I can figure this one out...
載入中...
載入中...
Fixed, thank you!
載入中...
載入中...
作者: Eridans, 09.02.2022 at 04:36

Procedure performed with Chrome
"World Map" clone
I select the inaccessible areas and delete them
Save the map
I exit the editor

Expected behavior
within 1 day if I go to the game or in the editor I should no longer find the inaccessible areas

Actual behavior seen with both Chrome and Microsoft Edge
They are no longer in the game, they are still in the editor and can be selected

Map on which I encountered the problem
"Eridans work in progress 03"


Further information
I have also seen this case study for the nations even if I have made several changes and it is difficult to give a sequence, however in the map:
"Error - All countries"
Russia in the editor is correct but in part it has in its interior there are areas inaccessible to land vehicles, for a test in the city:
"Test terra" there is a land unit called "Test terra" which has a large movement capacity, by that means it can be seen that a part is not accessible, the game actually considers it as sea, and corresponds to one of the Russian nations that I canceled

Chrome
Version 98.0.4758.82 (Official Build) (64-bit)

Microsoft Edge
Version 98.0.1108.43 (Official Build) (64-bit)


Hi Eridans,

Can you please check and confirm if this is still happening for you since the last map editor update?

I tested it just now and it's working correctly for me. I cloned the world map, deleted the no-go areas at the top, and saved. Then I started a new game, and confirmed the no-go areas were gone. Then finally I went back into the map editor again, and they were still gone.

Best,
Dave
載入中...
載入中...
Just to put a conclusion on this one -- this proved to be a complete waste of time. After going back in the logs, we discovered Daisy was playing Guerilla Warfare in order to get his "bad" inf rolls. He was actually using GW in the games where he demonstrated the "problem" to brianwl. So the whole thing, from start to end, was a hoax. Why people get kicks out of wasting our time like this, I'll never know. But there it is.
載入中...
載入中...
06.02.2022 在 atWar 2022 and beyond
載入中...
載入中...
Oof, thanks for the heads up. Will fix.
載入中...
載入中...
作者: SpicerIQ, 13.01.2022 at 10:21

All I can see now is the Main Room and Online players, I can't see who's actually in my lobby in list format. It is also not even in "others." It should at least be there so we can see how many players in a game so we can see if it's full or not


The server restart was done this evening, so this issue should be fixed now. Please let me know if you still have any problems.

Best,
Dave
載入中...
載入中...
作者: SpicerIQ, 13.01.2022 at 10:21

All I can see now is the Main Room and Online players, I can't see who's actually in my lobby in list format. It is also not even in "others." It should at least be there so we can see how many players in a game so we can see if it's full or not


This one is my fault. It seems that when I added the "online" tab I inadvertently bugged the pregame lobby's list. I have a fix for this already but it will require a server restart before it takes effect. I don't know yet when the next restart will be. I'll keep this thread open until then.

Moving this to the Bugs forum.
載入中...
載入中...
atWar

About Us
Contact

隱私條例 | 服務條例 | 橫額 | Partners

Copyright © 2022 atWar. All rights reserved.

加入我們在

將遊戲傳播出去!